Is Event Manager compatible with IE8?

Frequently Asked Questions

We're here to help! And that includes helping you save time. For faster results, please check out the following answers to commonly-asked questions first. If the information provided does not answer your question, you will have an opportunity to contact our Client Services team for assistance.

Some of the most commonly asked questions are answered here. If you cannot find the answer you are looking for, Contact Us.

Is Event Manager compatible with IE8?

The technology used to deliver the Event Manager functionality is not compatible with Internet Explorer Version 8 or earlier.  To use these features, you must use IE 9 or higher, or another browser such as ChromeFirefox or Safari.

If this was not helpful, please let us know so we can make it better.

Back to top